Introduction»

FontLab VI User Interface
FontLab VI User Interface

About this Guide»

This user guide is updated all the time, and the public version is automatically updated daily from our internal sources. If you encounter a printed version, be aware that the online version is likely newer—and also hyperlinked.

Everybody should check FontLab VI User Interface, particularly to learn about how to manipulate FontLab VI’s Panels, and how we differentiate between tapping versus holding keys for tools keyboard shortcuts.

What’s new»

The Release Notes page contains release notes of the public builds.

Preface»

FontLab VI is a professional font editor for Mac and Windows. We took FontLab Studio 5 and did a total rewrite from the ground up. Although some underlying FontLab Studio code and functions remain, FontLab VI is largely a brand-new application. It incorporates our favourite things from Fontographer, like the bold algorithm, and borrows conceptually from the very best implementations to make improvements, like in our Pen tool.

You can edit glyphs in isolation much like before, or in the context of other glyphs, and the tools and interface are more powerful and flexible now. In FontLab VI, we let you choose how you want to work, instead of us telling you that there is only one way to do things. The application is more streamlined and automatic, and gets out of your way as a designer to leave you free to design. The paint-bucket tool, smart corners, genius points, and several other innovations in the application were born out of this line of thinking.

Our objectives include:

File formats»

File compatibility with FontLab Studio 5 .vfb for most files, including in the functions of open and export (Exception: can’t save MM files back to Studio 5). Open and save UFO. Open files from Fontographer and Glyphs.

Updated, modern interface»

Retina compatibility»

Full cross-platform development»

Now our users can run FontLab VI on either or both Mac and Windows easily, and the two platforms are permanently in sync. Having ~98% shared code means we add new features on both platforms simultaneously, and most bugs are in common and fixed on both platforms at the same time. Even if you only use one platform, you will benefit from users and testing on the other.

We know it was a long wait. Thanks for using FontLab VI!

FontLab VI Quick Start»

  1. File > Open > Installed Fonts…

  2. Change the Cols selector at the bottom of Font Window to fit your needs.

    • Double-click on the “P” glyph to open the glyph for editing in a new Glyph Window.
    • See Font Window for more about the Font Window.
  3. Tap T to activate the Text tool.

    • Type some text and press Esc
    • See Text tool for more about entering text.
  4. Tap M to activate the Metrics tool.

    • Click on any glyph in the text to activate it.
    • Move the glyphs within the advance width with the pointer.
    • Enable View > Show > Spacing Controls.
    • Drag the sidebearing markers with the pointer.
    • See Editing Glyph Metrics for more on spacing.
  5. Tap A or 1 to activate the Contour tool.

    • If it has TrueType outlines, perhaps choose Contour > Convert > To PS Curves.
    • Move your pointer around the glyph’s contours to highlight nodes
    • Drag nodes with the pointer.
    • Open Window > Panels > View and click on the Nodes and Handles buttons.
    • Tap 2 to activate the Eraser tool.
    • Click on a node to remove it or on a handle to turn the curve segment into a line segment.
    • Hold 3 or J to activate the Knife tool.
    • While holding the key, click on the outline to add a node. Release the key.
    • Tap A and select some nodes using marquee.
    • Press CmdT and use the Free Transform tool to scale or rotate. Click away or press Enter to confirm.
  6. Choose File > Export Font As.

    • Select “OpenType PS” in the list at the left and click on Export.
    • You’ve just modified a font and generated a new OpenType font which FontLab VI saved in a folder on your Desktop.