Using the Glyph Window»

The Glyph window is the place where you create and edit individual glyphs. To open the Glyph window, double-click on any glyph cell in the Font Window or Font Map panel, or select the cell and press the Return key. To open several glyphs together in the Glyph window, select all of them in the Font Window or Font Map panel, and double-click on one of the cells or press the Return key. The Glyph Window has an editing area and it shares the Property bar with the Font Window.

Using the Property bar»

When you have a glyph (or several glyphs) open in the Glyph window with no nodes or contours selected, the Property bar looks like this:

Adding and editing glyph tags»

In FontLab VI, you can label glyphs with custom text tags. To add or edit a glyph tag, click on the Tags button in the Property bar to open the Tags pane. Here, you can type in a new tag, or modify an existing one. To add a tag predefined in FLVI, click on the V+ button in the bottom right of the pane. Predefined tags (known as virtual tags) include fig for figures, uc for uppercase letter and lc for lowercase letters. To save tags, click outside the pane. To delete all the tags in the pane, click on the cross in the bottom-left corner.

Flagging glyphs»

You can flag glyphs to visually differentiate groups of glyph cells to easily examine and select them. To flag a glyph, click on the flag dropdown and choose a color.

Switching between layers»

If you have more than one layer in your glyph, you can see them in the Property bar. To switch between layers, click on the button for the layer you want to switch to.

If there are more than four layers in the font, buttons turn into the dropdown menu.

Using the Content Sidebar»

Adding text to the Glyph window»

To open a text from the Texts library, click on the local menu Text. You can choose a text from the list, and it will appear both in the Glyph window, and in the text box below this menu.

To add a text to the Text library, type it into the text area in the sidebar or directly in the Glyph window, and then press the button. It will be added to the list you can access from the Text menu. You can also add texts to the library using Preferences.

To remove texts from the Text library, use Preferences.

Modifying formatting in the Glyph window»

To change the case of the text in the Glyph window, click on the button to covert to lowercase, and on the button to uppercase.

To set the text size in points, enter the text size in , or use the number stepper to change them, or click on and respectively to decrease and increase the text size. Note that the zoom of the window contents may not be set to actual size. To see your text at the selected size without zoom, click on the leftmost magnifier icon in the bottom-right corner of the Glyph window.

To set the tracking (distance between glyphs) of the text in the Glyph window, type a text into , or use the number steppers, or choose a value from the dropdown menu.

To set the leading (distance between lines of text) of the text in the Glyph window, type a text into , or use the number steppers, or choose a value from the dropdown menu.

Adding context to text in the Glyph window»

To add strings before or after the glyphs in Glyph window, type in the relevant string to the fields and respectively. This function can be useful when working on glyph metrics or kerning. For example, type HO in both fields will give you the following string of text:

Previewing OpenType features»

To preview OpenType features in the Glyph window, check the Features option in the sidebar, open the Features panel and compile the features in your font. Once the features in the font are compiled, you will see a list of all features in the Content Sidebar:

Once the features list appears, choose the script of your choice from the dropdown menu below the list and then check one or more features. They will be applied to the text in the Glyph window:

Click on the button in the bottom-right of the features’ list to unselect all features. Note that if the glyphs in the Glyph window are not impacted by the features you have selected, you will see no change.

Using the Text Bar»

Use View > Text Bar to show or hide the Text Bar, a horizontal text field at the top of the window. There, you can edit the “source” of the text that is shown in the Glyph window. The text bar works the same way as the text field in the content sidebar of the Glyph window, but some users will find it more convenient to work with the content sidebar closed but have the text bar visible.

On the right side, the text bar has a dropdown menu that allows you to choose one of the texts predefined in Preferences > Texts. This is the same dropdown available under the Text button in the content sidebar.

The text bar uses the “glyphtext” notation, so you can input Unicode characters directly (AÄĄ etc.), or you can input glyphnames using the /glyphname format (e.g. /A/Aacute/Aogonek), or hex Unicode codepoints using the \uXXXX format (e.g. \u0041\u00c4\u0104). If you want to enter an explicit Unicode character right after a glyphname or a hex codepoint, enter a space first (e.g. A/Acute Ą).

Working in the editing area»

Switching between glyphs»

Once you have opened a glyph in the Glyph window, you don’t need to go back to the Font window or Font Map panel to switch between glyphs.

To move to the next glyph, select Glyph > Next Glyph or use the keyboard shortcut Cmd-].

To move to the previous glyph, select Glyph > Previous Glyph or use the keyboard shortcut Cmd-[.

To switch to a specific glyph of your choice, press the / key and start typing the desired glyph name in the popup pane:

Press Enter to place the first available glyph in the Glyph window, or click on the glyph you need in the list.

Searching for glyphs»

To search in the Glyph window, select Edit > Find Glyphs or use the keyboard shortcut CmdF. Once the panel opens, start typing in the text field, and choose from the criteria on the left: name starts from, name contains, name ends with, Unicode name contains, codepage, Unicode code point contains and tex match. To open all the glyphs in the searched list, click on the icon and press Return. To open a single glyph from the list, double-click on the glyph cell.

Editing several elements together»

To see and edit the nodes of all the elements in the Glyph window, turn on Edit > Edit Across Elements. When Edit Across Elements is turned off, you can see and edit the nodes of only the current glyph.

Editing several glyphs together»

To see and edit the nodes of all the glyphs in the Glyph window, turn on Edit > Edit Across Glyphs. When Edit Across Glyphs is turned off, you can see and edit the nodes of only the current glyph. You can also use the keyboard shortcut AltCmdE to toggle between the states of Edit Across Glyphs.

Editing several layers together»

To see and edit the nodes of all the layers in the Glyph window, turn on Edit > Edit Across Layers. When Edit Across Layers is turned off, you can see and edit the nodes of only the current layer.

Wrapping text»

If you are working with several glyphs in the Glyph window, you may want to control how the string of text is wrapped. To access text wrap options, go to Text > Wrap. There are three options available:

  1. Manual, where the entire text is rendered as a single line, only interrupted by manual line breaks:

  1. Auto, where the entire text is rendered in a fixed-size column; currently it’s not possible to change the width of this column:

  1. Table, which renders the text as a table of glyph cells:

In all three ways of text wrapping, the glyphs stay editable.