Thank you for choosing FontLab VI!

We listen to your feedback, and have regular updates. If you find problems (bugs, crashes etc.), please report them. Your feedback is crucial to help us give you a better app!

Release Notes»

FontLab VI version 6.0.5.6675»

12 April 2018

FontLab VI 6.0.5 is our biggest “dot release” to date, with over 100 improvements (40 new features or enhancements, and 60 bug fixes)!

New Features and Enhancements»

Autosave and Auto-Recovery»

When you enable the new option, Preferences > Save Fonts > Autosave opened fonts every … minutes, FontLab VI will automatically keep saving a backup copy of your working files as you work. You can set the frequency of autosaving in minutes, but you can also use fractions, e.g. if you enter 0.1, FontLab will autosave every 6 seconds.

The autosaved files do not overwrite the location where you are manually saving the file. Instead, they are stored in the ~/Library/Application Support/FontLab/FontLab VI/Autosave folder on macOS and in C:\Users\USERS\AppData\Roaming\Fontlab\FontLab VI\Autosave on Windows.

When you close a file or quit FontLab normally, and choose to either save or not save the opened file, the autosaved file will be deleted. But if your FontLab crashes and you start it again, it will detect the autosaved files and offer to automatically recover (reopen) them.

Note: We recommend the following Preferences > Save Fonts settings:

  1. Ask for the font file name — when you first save your font, FontLab will ask for the location and filename to save, subsequent saves will be done in the location you’ve chosen.
  2. Existing font files is set to Rename. Then, whenever you manually save a file (for example YourFileName.vfc), the previously-saved version will be renamed to YourFileName.YYMMDD-hhmm.vfc, where YYMMDD-hhmm is the date and time of when it was renamed. This serves as a series of auto-backups — you can always open any of the earlier versions if you’ve changed your mind about some edits.
  3. Autosave is enabled and set it to some reasonable setting. For example, 1 will autosave (in the special folder) once a minute, 0.1 autosaves once every 6 seconds (1/10 of a minute).

You may also enable any of the Save VFC and also options, but note that this will make your saves and auto-saves slower—especially if you’re saving UFO packages.

In short: with this release, you can have:

  • manually saved files (in the location you pick)
  • automatic backups of your manually saved files (in the same location)
  • the last autosaved version (in the special folder)

Drawing and Editing»

Easier editing with integer coordinates»

You can restrict FontLab VI to always work in integer coordinates. The new submenu Contour > Coordinates give you full control over integer coordinate rounding.

  • If you have fractional coordinates in a glyph, Apply Rounding will round them to integer coordinates in the current glyph layer, or (when used in Font Window) to all contours in the current glyph layer.

  • With the new Round when Editing setting, any editing (moving nodes and handles, scaling glyph content using the Free Transform tool) will produce integer point coordinates (like FontLab Studio 5). This setting will not modify your existing contours (for that, you need to run Apply Rounding, but with the setting on, your editing actions in the Glyph Window will always produce integer coordinates (except in the case described in the note below).

  • Note: Applying Rounding and Rounding when Editing will currently work only if the glyph does not use transformed elements. Currently, when you use the Transform panel or any transformation Action, FontLab VI will apply a non-destructive “element transformation” to any elements that have references (i.e. they’re in a composite glyph or they are used as a component in a composite glyph), and will apply a “contour transformation” only if an element in a glyph does not have references. The integer rounding always works on the contours in an element before their transformation is applied. We’re looking into how we can make the way transformations work more intuitive.

  • The Preview Rounding setting will also preview rounded coordinates within transformed elements — which is the result you’ll get after you export your fonts into font formats that use integer coordinates.

Other drawing and editing enhancements»

  • Preferences > Glyph Window > Show node name has a new third option, never. This option only affects Glyph Window viewing, node names will still be displayed in the Nodes panel.

  • During Free Transform, Undo cancels the transformation process in the same way it did in FontLab Studio 5, and does not undo the previous action

Variations»

Glyphs are created in all masters»

FontLab will now always create master layers if you create or generate a glyphs — for all font masters defined in Font Info.

Previously, when you had multiple font masters defined in Font Info, then adding a new glyph via double-click in the Font Window on a blank glyph cell, via Font > Generate Glyphs or Font > Add Glyphs behaved differently depending on whether a generation recipe glyph was present in the bundled alias.dat file.

When a glyph could be “generated”, its contents would be created for all font masters, but if the resulting glyph would be blank, then no masters were created in the glyph.

Generate Instance»

The new Font > Generate Instance command will allow you to choose any of the predefined instances or use sliders to precisely choose your instance and then:

  • Add as Master — add the instance as a new font master to the current multiaxis font in the axes location of the instance
  • Create as Font — create a new “static” font from an instance; the font will open as a new font in FontLab, so you can perform some post-production and save or export it

Previously, this functionality was only available in a limited fashion under the top-right button of the Variations panel.

Masters and axes sorting»

In Font Info > Font Properties > Masters, you can now sort your masters automatically and manually.

Clicking on the header above the font sample will sort the masters according to the way the axes are sorted, and then by the location of each master on an axis (you can sort your axes manually via drag-and-drop in Font Info > Font Properties > Axes).

Clicking on the Name or Location header will sort the masters alphabetically by the content of these fields. Click once for a descending sort, click again for an ascending sort.

You can also sort the masters manually via drag-and-drop.

Click on Apply or OK, and the sorting of your masters will be reflected in the Layers and Masters panel and in the masters switchers on top of the font and glyph windows. The order of the masters also is used when you switch the masters with Alt,/Alt., or with the Alt1 to Alt9 keyboard shortcuts.

The order of Axes in the Variations panel is now in sync with the order defined in Font Info.

Initial default sorting of axes when opening an existing font for the first time is improved.

#instance layer»

  • Viewing the #instance layer can be turned off in Preferences > Variations

  • Preview of the #instance layer is now live while you are editing a contour

Improved “Match Masters”»

The Glyph > Match Masters operation has been improved:

  • with any number of masters, when Sort contours and start nodes is on in Font Info > Axes or in the Variations panel, Match Masters will sort the contours and start nodes in a simple way

  • with any number of masters, when Check masters geometry is on in Font Info > Axes or in the Variations panel, Match Masters will sort the elements, and will perform more thorough geometry checking (including checking angles and rotation) when sorting the contours and start nodes, and will also will correct the contour direction if needed

  • with two masters, it will also attempt to “blend” the outlines i.e. automatically add or remove nodes on the contours

Other variations enhancements»

  • Extended parameters control. The Parameters tab in the Font Info panel / dialog now includes all values that can act as a parameter: font dimensions, font guides and user variables.

  • Font Info panel: Tooltips in the Parameters tab of the panel show correct information.

  • Hiding a layer also hides that layer’s associated Mask layer

  • Turning off Append master fonts removes the #instance layer from affected single-master fonts

  • FontLab VI uses the a newer build (3.24.3.dev0) of the fontTools library to export OpenType Variations TT (.ttf) fonts

Elements and Guidelines»

  • In the Element panel, when an element is locked, users can no longer do drag-drop reordering of contours within the element

  • Edit > Invert Selection (CmdI) works with the Element tool at the level of element selection (not only for contours)

  • Guideline panel (metrics, hints, alignment zones)

    • when a guideline that represents one of the font metrics (ascender, descender, caps heigth, x-height, baseline) is selected:

      • just two fields are active in Guideline panel, Position and Expression, as no other value is editable for font metrics.
      • an option to lock/unlock the font metrics is available
    • When a hint is selected in the Glyph window, the prefix “H” is shown in the Guideline panel

    • when an alignment zone is selected in the glyph window, the prefix “Z” is shown in the Guideline panel

    • when hints, links or alignment zones are selected in a Glyph window, the Properties controls in the Guideline panel are disabled as they aren’t applicable.

Classes and Kerning»

Classes panel»

With one or more classes selected in the Classes panel, you can now click on the Select glyphs button in the panel’s lower-right portion to select (in the Font Window) all glyphs that belong to the selected classes (like FontLab Studio 5).

This way, you can quickly assign a color flag to those glyphs (using the color flag picker in the Font Window).

You can also easily merge classes — select multiple classes, click on the Select glyphs button and then click on the + button in the bottom section of the middle part of the Classes panel. The selected glyphs will be added to the first class that you’ve selected, and — if this was a kerning class — they will be removed from the other kerning classes of the same type.

The Classes panel hamburger menu item Clean up selected classes will remove any glyphs from selected classes that are not present in the font (remember that classes can be defined using glyphnames and not all glyphs must necessarily exist in the font).

Note: In FontLab VI:

  • OpenType classes are defined once per font, and the order of the glyphs inside these classes matters.

  • Kerning classes are defined per master, but when instances or variable fonts are exported, classes from the main master are used (you can set the main master in Font Info > Masters using the blue radio button). To ensure that you have the same kerning classes in all your masters, visit each master and use the hamburger menu of the Classes panel to Import Classes, picking the main master each time.

  • When building variable fonts, kerning pairs that don’t exist in corner masters are assumed to have the value 0 but kerning pairs that don’t exist in intermediate masters get the interpolated value.

  • Kerning values that involve classes are stored with the class, not with the “key glyph of the class” as they were in FontLab Studio 5.

Kerning panel»

The Kerning panel has a few new operations in its “hamburger” menu (the popdown menu with three horizontal lines):

  • With Import Kerning you can import the kerning pairs and values from another open font or another master of your current font

  • With Flatten Class Kerning (previously: Expand), all kerning pairs that involve classes (class-to-class, glyph-to-class, class-to-glyph) are converted into a large flat list of glyph-to-glyph pairs.

  • With Compress to Class Kerning, you can convert your flat kerning into class kerning “safely” — only pairs where all class members have identical flat kerning values will be converted into a class kerning pair.

  • With Extend Class Kerning, you can convert your flat kerning into class kerning “more aggressively” (see notes below). This operation is great when you’ve kerned individual glyph pairs already (using flat kerning), and then you’ve created some classes or added glyphs to classes, and you want the glyphs in the new classes to inherit the kerning of the previously-defined individual glyph kerning pairs.

Notes:

  • When you run Flatten Class Kerning, the kerning classes aren’t removed. They are simply not used because the kerning pairs are now associated with glyphs.

  • In this build, when you run Flatten Class Kerning, the list of flattened kerning pairs will include kerning pairs for glyphs that are defined in the kerning classes but aren’t present in the font. This is a bug — please select all classes in the Classes panel and choose Clean up selected classes before flattening kerning.

  • The difference between Compress and Extend is the following: if you have two kerning classes (AÁÄ and VW) you have two flat kerning pairs (AV and AW) with the same value, but there are no flat kerning pairs that involve the Á or Ä glyphs, then:

    • Extend Class Kerning will produce one kerning pair between the AÁÄ class and the VW class; so after the operation, the glyph combination ÄV will have the same effective kerning as AV.
    • Compress to Class Kerning will produce one kerning pair between the A glyph and the VW class; so after the operation, the glyph combination ÄV will have no effective kerning.
  • The Flatten and Compress operations are fully reversible. When you have flat kerning, create some classes, then Compress and then Flatten, you’ll end up with the same number of pairs as you had before.

  • The Extend operation is more aggressive. When you have flat kerning, create some classes, then Extend and then Flatten, you’ll end up with more pairs than you started with. When there are some flat kerning pairs with one value and some flat pairs with another value, but glyphs that are kerned that way belong to the same kerning class, Extend will choose the more common value as the class kerning value, and the less common value as a series of exceptions.

Font Window»

  • New Font Window options: Unicode Categories, Scripts. Now the Font Window can be organized by Unicode Categories (Uppercase, Math Symbols, Punctuation, etc.) and Unicode Scripts (Latin, Cyrillic, Greek, etc.). This is in addition to the previous Encoding, Unicode, Codepage and Index viewing. The same viewing options are available in Font > Add Glyphs for adding new glyphs.

  • Preferences > Font Window now has options to set a default mode and default glyph sorting order (in addition to the default encoding).

User Interface»

  • The File > Font Info dialog box now has an Apply button which applies the ongoing changes to the currently opened font. Note: you actually need to click on Apply if you add, remove or rearrange axes in Font Info, only then the changes are visible in the Masters section of Font Info.

  • Renaming a master in Font Info > Master Properties > Names > Master name is instantly visible in the top and left-bottom master selectors.

  • Numeric keypad Enter key works for dialogs just like the main Enter key.

  • Preview panel automatically scrolls as needed to show the current glyph

  • Weight, Width, Slope and “Other” style attributes are referred to as Attributes in the Font Info panel. Previously, they were called “Parameters” but that term also was used elsewhere for another purpose.

  • Running the operation “Glyph > Add Power guides” makes font metrics and alignment zones visible, if they are made into Power guides and were not set to visible before. It also connects nodes from both sides of horizontal stems, not just one side.

Actions»

In Tools > Actions > Effects > Engraving it is now possible remove the image selected as a background (not only to add it)

OpenType Features»

The Features panel hamburger menu items Import Features File… and Import Features (from another open font) works even when the feature definitions reference glyphs that are not present in the current font. This way, you use a larger, pre-defined feature definitions file but create just the features your font needs .

Hinting»

  • The Preferences > Autohinting section now has two options for PostScript autohinting:

    • When Remove existing hints when autohinting a glyph is on, and you do Tools > Autohint or press F7, FontLab will remove the existing glyph hints before calculating new hints.

    • When Convert hints to links when autohinting is on, and you do Tools > Autohint or press F7, the hints will be subsequently converted to links (same as Tools > Hints to Links). Links are “dynamic hints” — when you move nodes, the links will follow your design changes. This is particularly useful when you use View > Show > Hints or View > Metrics and Hinting Shadows as a visual design aid.

  • When View > Show > Hints is on, hint thicknesses that correspond exactly to stem values defined in Font Info > Master Properties > Stems are rendered bold on screen.

  • In the TrueType Hinting tool, the popup for the Single Link command now has a Reverse button which reverses the direction of the link.

Production»

  • PostScript Type 1 font export now generates fonts with “custom encoding” instead of “standard encoding”, and the %!Windows Charset:238 special keywords in an .enc file are processed correctly. In this build, all Type 1 fonts will get custom encoding. In a future build, encodings will %!Windows Charset:0 will get standard encoding again.

  • Automatic Unicode assignment based on glyph names no longer assigns the Unicode values for phonetic small caps to glyph names such as “Asmall”. These names were standard for Adobe Expert Encoding, where they were typographic small caps. The phonetic small caps are not a complete set (not even A-Z) and cannot be used meaningfully for typographic small caps.

Bug Fixes»

Drawing and Editing»

  • Convert line to curve works even when a line is bracketed by two tangent nodes

  • Creation of handles by Alt-dragging a node is now more reliable

  • Open contours can be joined with the Pen tool

  • Edit > Find Outline replaces contours correctly, even when replacing multiple instances of the same contour

  • Pressing spacebar changes the cursor to a grabber hand (to pan the canvas) even when Brush tool is selected

  • Snap to grid continues to affect Pen tool even after switching to Contour tool, moving handles, and switching back to Pen

  • Snap to grid works even if grid opacity is set to zero

  • Guidelines now snap to the Grid if View > Snap to > Grid is on

  • Node coloring becoming solid when perpendicular continues to work even when handles are close to the node

  • Snap-to-node works even when dragging a point to a node that is on a guide

  • Activating Power Nudge temporarily by holding the c key and using shift-arrow key combinations with it does not cause Power Nudge to get “stuck” on.

  • Transforming selected contours doesn’t change node types

Glyphs, Elements and Color»

  • When a sticker is applied to a glyph, and the VFC file is saved and closed, the sticker is saved

  • An element with smart fill filter rotates and moves correctly now

  • Dragging an element to an empty glyph cell no longer crashes the app, and does not cause a name/Unicode conflict when the glyph is created.

  • Copying an element from one glyph slot to another

  • no longer changes the element location within the glyph

  • no longer creates a new separate element with a conflicting name

  • Element frames are slightly more visible now

  • Doing Font > Detect Element References does not break ability to move a selected node with the arrow keys

  • When you have two or more elements selected, and they belong to a larger group, you can still nudge or drag all the selected elements (not only the last one selected)

  • Tools > Remove Font Guides no longer removes zones as well as font guides

  • Adding a new font master filled with an existing layer does not break the element references on that duplicated layer

  • Element references are not displaced when adding a layer that duplicates the contents of another layer

  • Font > Detect Element References does not remove element guides

  • Element > Expand Filters can now be Undone

  • Element > Expand Stroke can now be Undone without creating duplicates

  • Expand Stroke respects stroke end caps, even when applied to multiple glyphs

  • Elements > Expand Filters works even when the Contour tool is active

  • Some stroked elements were previously rendered incorrectly

  • Apply buttons in the Colors and Swatches panels are enabled after the Glyph window closes

Variations»

  • Anchor cloud (from View > Anchor Cloud) from only the current master is shown in the Glyph window

  • Masters for empty glyphs such as “space” are shown as compatible in the Layers & Masters panel

  • Exporting a master does not break the family name

  • Fixed problem where “Check masters geometry” could prevent interpolation

  • Adding axes in Font Info > Axes no longer adds duplicate axes especially after master switch

Production»

  • Exporting TTF from VFB source with manual TrueType Hinting created in FontLab Studio 5, preserves that hinting properly

  • Export of variable fonts works again

  • Kerning is correct in all masters exported from a variable font.

  • Glyphs using multiple instances of the same element no longer lose any of them on export

  • When a Type 1 font’s glyph has a BBOX of 0, a generated AFM file still gets correct semicolon line ending

  • Generated AFM files use LF for line endings instead of (old-school Mac OS) CR

  • You can export a completely unhinted Type 1 font (autohinting only kicks in if you tell it to do so)

Other»

  • Transformations applied in the Elements panel become instantly visible in the Font Window

  • No crash from using Tab to show/hide panels

  • The very last changed field in FontInfo keeps its changes after you click OK

  • Trying to close a file while in the middle of saving it does not abort the save, nor crash the app if done repeatedly

  • When a color flag on a glyph is removed, and the VFC file is saved and closed, the flagging remains removed when the file is reopened

  • Copyright symbol in Font Info > Legal > Copyright is now displayed correctly

  • Fixed intermittent crash when using Add Power Guides

  • Undocked toolbar is no longer cut off when app window is resized

  • Preview panel still shows the correct layer after Contour > Apply Rounding

  • Fixed crash that happened when switching layers/masters in the Layers & Masters panel, in some circumstances

  • You can still rename glyphs in place in the Font Window when == Preferences > Font Window > Caption content is editable== is set, Unicode > 1F00 Greek Extended is selected in Encoding, and other panels are open.

  • When a vector guideline is selected, the position icon in the Guideline panel changes to the point of origin icon

  • Glyph is no longer re-centered unexpectedly unexpectedly when working on a master that is specific to just the current glyph

  • Edit > Copy now copies text correctly in the text mode of the Glyph window

  • Using the “Center in Metrics” button in the Elements panel doesn’t crash

  • Using Font > Link Glyph Metrics with “Apply to entire font” on very large fonts no longer causes a crash

  • Closing the Font window now closes the font when needed (if Preferences > General are set to “Font has at least one Font window”)

  • Wacom tablet: canvas now auto-scrolls properly when drawing

  • Arrow keys work reliably in pane with glyphs (invoked with the / shortcut).

  • Font Info > Master Properties > Other Values are saved to vfc files

  • “Unsaved” marks in Font Window don’t disappear right after save

  • Guideline panel: The prefix “H” is shown in the panel, when a hint is selected in the Glyph window; and the prefix “Z” when an alignment zone is selected.

  • Other minor/cosmetic UI issues

FontLab VI version 6.0.4.6634»

9 March 2018

New preview build of FontLab VI for Windows x64»

This is for Windows users only: Today, we’re releasing a preview build of FontLab VI for Windows x64. Most Windows users can continue to use the 32-bit version of FontLab VI, which works in both 32-bit and 64-bit editions of Windows 7, 8.x or 10, and which is available via the Install Update at the bottom of the FontLab VI built-in auto-update dialog.

But if you’re interested in testing the preview-quality native 64-bit for Windows, visit the FontLab Forum.

Note: If you’re a Mac user, your FontLab VI is already 64-bit and you can completely ignore the above.

New features»

Text Bar»

In the Glyph Window, use View > Text Bar to show or hide the Text Bar, a horizontal text field at the top of the window. There, you can edit the “source” of the text that is shown in the Glyph Window. The text bar works the same way as the text field in the content sidebar of the Glyph Window, but some users will find it more convenient to work with the content sidebar closed but have the text bar visible.

On the right side, the text bar has a dropdown menu that allows you to choose one of the texts predefined in Preferences > Texts. This is the same dropdown available under the Text button in the content sidebar.

The text bar uses the “glyphtext” notation, so you can input Unicode characters directly (AÄĄ etc.), or you can input glyphnames using the /glyphname format (e.g. /A/Aacute/Aogonek), or hex Unicode codepoints using the \uXXXX format (e.g. \u0041\u00c4\u0104). If you want to enter an explicit Unicode character right after a glyphname or a hex codepoint, enter a space first (e.g. A/Acute Ą).

Note: The /glyphname format allows you to input alternate glyphs, small cap glyphs etc. explicitly — even if you don’t have any OpenType features defined in the Features panel. But if you do have features defined, you can compile them in the Features panel, and then also access alternate glyphs by entering normal Unicode text and enabling features in the content sidebar.

Import features from open fonts»

The Features panel now has the Import Features submenu that allows you to import the feature definitions from another currently open font.

Variations enhancements»

If you’re working on a font family or a variable font, and have a font with multiple masters:

Generate Glyphs works for all masters»

In Font > Generate Glyphs, you can choose to generate the glyphs in all masters or only in the current master. Previously, glyphs were generated only in all masters.

Linking metrics across masters»

In the Width, LSB or RSB fields of the Metrics table for a given master, you can now enter the name of another master. For example, in the Black master of the O glyph, you can enter Light in both the LSB and the RSB fields.

Then, if you change the sidebearings of the Light master in the O glyph, and run Font > Update Metrics (CmdAltM on macOS, CtrlAltM on Windows), the sidebearings of the Black master of the same glyph will be updated to the same value.

Note: If you enable Preferences > Spacing > Automatically update linked metrics, the linked metrics will be updated automatically as you edit them, but only within the current master. Automatic updating of linked metrics across masters would be too slow, so you need to run Font > Update Metrics to update across masters.

In addition to using the full master name in any of the metrics fields, you can use an abreviation. For example, if you want to link the width of the Black O to the ExtraLight O, you can write Ex. or ExtraL. (using the period). As long as the abbreviated master name is unique, it’ll work.

Also, rather than linking to just the specific value, you can use more complex expressions. For example, you can enter Light+20 in the RSB of the Black O, and then it’ll be equal to the RSB of the Light O plus 20 font units.

Synchronize sidebearings or widths across masters»

With the new action Tools > Actions > Metrics > Synchronize sidebearings, you can copy either the advance width or the sidebearings from the current master into all visible layers or into all masters. This will copy the actual numeric values, not the expressions. You can copy the absolute values or the values calculated at a certain y coordinate (Use the measurement line).

This is particularly useful when you’re working on a font family or variable font where metrics are supposed to be identical across masters. This is also useful if you want to use one master’s metrics as the starting point for spacing another master.

Note: You may choose if you prefer to link the metrics to another master using the expressions (so any future metrics changes in one master will propagate to the linked ones), of whether you use Synchronize sidebearings which just copies the values without linking.

Customizable background color per master»

In the Layers and Masters panel, you can assign a custom color to any master.

Using the new Preferences > Variations > Preview master color setting, you can view the custom master color as a thin colored line on the top of the Glyph Window, or as a “pale” background color of the entire Glyph Window (with customizable transparency).

Now you can easily differentiate which master you’re currently working on, so you won’t make changes to the wrong master by mistake. This is particularly helpful if your master designs only differ slightly (for example, in the length of the ascenders), or if you’ve duplicated a finished master and are adjusting (condensing etc.) the new one.

Previously, the master color was only used if you declared a layer or master “wireframe”. Then, in the Preview panel and when using Quick Preview (Space key), the contours of that layer or master were rendered as outlines colored in the custom color (rather than being rendered filled).

Keeping References on instance generation»

When you use one of the two top-right buttons in the Variations panel to add a glyph master (1st button), add a Font Master (2nd button, 1st option), or create a standalone font (2nd button, 2nd option) based on the instance that is currently selected in the Variations panel, FontLab will now:

  • keep the element References (composites). Previously, references were kept when exporting the font but not when using those buttons.
  • keep the glyph color Flags
  • keep the kerning classes and pairs.

Better export of OpenType Variations TT (.ttf)»

FontLab VI uses the a newer build (3.23.1) of the fontTools library to export OpenType Variations TT (.ttf) fonts. The exported fonts will have the STAT table, and some variations-related tables are optimized thanks to the excellent work of the fontTools maintainers.

Design workflow enhancements»

Mirroring glyphs in Font Window also mirrors anchors and sidebearings»

The commands Tools > Transform > Flip Horizontal and Flip Vertical can be triggered from the Glyph Window or from the Font Window. If you invoke these commands from Font Window (with one or more glyphs selected), the transformation will now also affect anchors and sidebearings, producing a complete mirror result. This is useful for building glyphs which are flipped versions of others.

Easily add nodes at extremas using the Knife tool»

When your contour lacks an extrema and you activate the Knife tool (tap or hold J), you can also then press Shift. With Shift pressed, when you move the pointer over the contour, the Knife tool will suggest the node insertion at the closest extrema rather than at the exact pointer position.

Easily duplicate TrueType off-curve points»

With TrueType outlines, CmdD / CtrlD now works to duplicate TrueType off-curve points the same way as on-curve points.

Curvature for all elements with Edit Across Elements»

When both View > Show > Curvature and Edit > Edit Across Elements are on, the curvature is now shown for all elements, not just for the current element.

Index mode of the Font Window appends glyphs»

In the Font Window in Index mode, CmdV / CtrlV appends glyphs instead of overwriting them, like it did in FontLab Studio 5.

Mask layer shown in Preview panel and Quick Preview if active»

When the Mask is active, the Preview panel and the Quick Preview (activated with Space) shows its contents and not the normal layer.

User interface enhancements»

Customizable color of baseline and sidebearing lines»

View > Show > Spacing Controls shows and hides the Metrics lines (the glyph’s baseline and the sidebearing lines) in the Glyph Window. Now you can customize the color and transparency of the Metrics lines using Preferences > Spacing > Metrics lines, so you can make them appear darker, lighter, or give them another color altogether.

Better closing of Glyph tabs»

When you have multiple fonts open, and you close a glyph tab, the font tab corresponding to the closed glyph will be activated. Previously, the last active font tab was activated, which did not necessarily correspond to the glyph tab you just closed.

Content sidebar in the Glyph Window»

Tooltips added to all UI elements.

Python API»

Note: The Python API is still under development and is subject to change.

Use of anchor array in scripts. The anchor array is now working correctly, including fonts imported from FontLab Studio 5. Note that your script need to check the validity of any “global” object (like flGlyph, flLayer, flShape and flContour) by calling .isValid() method before using them, as in this sample script:

import fontlab as vi
font = vi.CurrentFont()
for fg_glyph in font.glyphs:
  fl_glyph = vi.flGlyph(fg_glyph, font)
  if fl_glyph.isValid():
    activeLayer = fl_glyph.activeLayer
  if activeLayer.isValid():
    anchors = activeLayer.anchors

Bug Fixes»

  • Copy Outline to Mask works even when Mask is not empty
  • Generate Glyphs no longer crashes when Link Shapes option is off
  • Undo works in Transform panel, without requiring you to click in the glyph window first
  • Doing more than one Set Startpoint in a single glyph does not crash the app
  • Copying an element reference and pasting it into a new glyph no longer causes a crash
  • When adding a new OpenType class in the Classes panel, the initial report on number of glyphs is correct instead of always being zero
  • Tools are disabled in the Font Window when the selected cells do not contain existing glyphs
  • In the search panel invoked by the / key, gesture scroll works as expected and the start focus is at the first result of the search
  • When the only reference of a named element is deleted from font, it is immediately removed from Gallery panel. Note: removing a reference of a named element that has additional references in the font will not remove it from the Gallery
  • Date in text of compiled features is correct
  • Remove button on Brush property bar works in cases it didn’t before
  • Opening certain damaged VFC files no longer crashes the app
  • Tools > Actions > Metrics > Set Width option to center elements works more consistently
  • Hitting Enter in a FontAudit interactive dialog now fixes the problem rather than just closing the dialog
  • In Kerning mode, corrected tooltip for the Remove Pair button
  • When working with strokes on contours, metrics and sidebearings are still calculated correctly
  • Fill tool works as expected even with very complex nested fills-inside-fills-inside-fills
  • Changing text size in the Metrics/Kerning modes respects the Center on Glyph option of the Metrics tool context bar menu
  • In text editing modes, the dynamic glyph filtering in the insert dialog (triggered by the / key) correctly filters names that include a period (such as A.smcp)
  • The numbers in the tracking field of the custom sidebar can be used to set a negative tracking value; the tracking field in the custom sidebar now displays negative values correctly
  • Pen tool coordinate display starts when the tool is selected, not only after the first node is placed
  • If View > Show > Grid and Preferences > Grid > On-curve nodes always snap to grid are both activated, Rapid tool no longer shows fractional values before the first node is placed
  • If a font metric is selected in the Glyph window, the Guideline panel only shows its name (not editable), position (editable) and the option to lock it. Things that don’t work on font metrics such as color, width, tags and marks are no longer shown
  • Submenu entries of the Help > Commands dialog now correctly show as Import/Export Custom Shortcuts. Note: Only customized shortcuts are saved in the data file, which confused some users who thought all shortcuts are being saved
  • Fixed focus problems in Glyph Info panel, which could lead user to think app was locked up
  • Undo now works on Tools > Remove Glyph Guides
  • Fixed bug with Contour > Preview Rounding that caused incorrect rendering of TrueType outlines
  • Switching to Text mode and back no longer hides guidelines, zones and font metrics
  • PostScript Type 1 fonts (.pfb) can be saved even when the path contains non-Latin characters
  • After you move the Metrics table to the top of the window, you can move it back to the bottom if you wish
  • Mac-only: Fixed redraw issues on Sketchboard when Preferences > General > OpenGL is off
  • Windows-only: Keyboard shortcuts for editing left sidebearing work correctly
  • Windows only: the font size for captions in the Gallery panel is now smaller
  • Windows-only: Resetting keyboard shortcuts in the Help > Commands dialog no longer displays/creates incorrect Meta key shortcuts in menus

FontLab VI version 6.0.3.6611»

7 February 2018

New Features: User interface»

New Commands dialog & custom keyboard shortcut editing»

The new Help > Commands dialog box lists all commands available in the main app menus, including custom workspaces and scripts.

Use CmdShiftP to open the dialog, and type in a phrase to locate a command.

Then, navigate to the command with cursor keys and press Enter to execute that command. Inspired by similar solutions in apps like Sublime Text or Atom, this is a very fast way to invoke various commands which does not require to use the mouse or to remember keyboard shortcuts.

And (yes!) you can also customize (assign and change) the keyboard shortcuts associated with any of these commands. Use the shortcut field below the command list to remove an existing keyboard shortcut or assign a new one.

Note: there are some keyboard shortcuts, e.g. the single-letter keystrokes used to invoke the tools, which are not customizable. But most menu commands are now customizable, and you can export and import those customizations easily.

New Features: Drawing»

Swap Outline with Mask»

Tools > Swap Outline with Mask (CmdAltH Mac, CtrlAltH Windows). Added this command familiar to FontLab Studio 5 users

Node coloring for vertical and horizontal handles or line segments»

Under Preferences > Glyph Window > Node Style there is a new setting (in the middle), which is also the new default. When this “auto fill” setting is selected, nodes will be rendered as fully filled (darker) or semi-transparently filled (lighter), depending on the position of the node and its handles.

If a node is between curve segments and its handles are aligned perfectly vertically or horizontally, the node is fully filled (darker in color). If a node is between line segments and both segments are perfectly vertical or horizontal, the node is also fully filled. Otherwise, the node is semi-transparently filled (lighter in color).

This helps identify points that are not quite where you intended, or are not quite proper extrema.

Shift-double-click to align nodes and handles»

If you have a node or handle that is nearly aligned (in either X or Y) with an adjacent node, this will shift it to become aligned. When applied to extrema nodes with handles that are not perfectly aligned to X or Y direction, shift-double-click will fix that.

New Suggest Guides option»

When View > Suggest > Suggest Guides option is activated, hidden guides, hints, zones or font metrics temporarily appear when you move a node or contour near them. This only works with guides/hints/zones which have “snap to” allowed (View > Snap menu or in the View panel). This allows you to keep a clean workspace where guides, hints, zones or metric lines are invisible, but they become visible just when you need them.

This feature combines well with View > Metrics & Hinting Shadows option for easier navigation.

Nodes on alignment zones are optionally highlighted»

If you move a point into an alignment zone, the node is highlighted with a light gray circle if the node is on the edge of a zone or with a light gray rectangle if the node is inside the zone.

This behavior is on by default, but can be turned off as the fourth option under Preferences > Editing > Highlight nodes on alignment zones.

Snap to glyph metrics»

This new option under View > Snap > Glyph Metrics causes snap to sidebearings, and applies to all operations where snap works.

New Features: Languages and Production»

Import Ikarus (.ik) Files»

Support for import of Ikarus font files (which typically come with .cha file containing glyph names and Unicode indexes) is back in this build of FontLab VI. To keep precision of the source data, low-error-tolerance approximation is applied to Ikarus contours when they get converted to cubic Bezier splines. This results in high accuracy but more points; consider Simplify or Clean Up operations after the import.

Codepages & Unicode ranges»

Font Info now has two new sections for setting code pages and Unicode ranges, much like FontLab Studio 5. You can still use the “auto” (diamond) button to have FontLab generate what it thinks are the right flags, and you can set them manually. The information will be stored in the OS/2 table of the exported OpenType font.

Features checkbox in the content sidebar»

The Features checkbox in the content sidebar not only allows you to enable and disable OpenType Layout features, but also activates the HarfBuzz-based Unicode text preprocessing (script itemization, bidirectional support and Unicode normalization).

Previously, you could only enable the Features checkbox if you had features defined in the Features panel. Now, you can enable the checkbox even if you don’t have any features defined, so you can use the Unicode preprocessing and bidirectional support.

Note: Bidirectional/RTL support is still flaky in this release, we’re working on it!

CID-keyed glyph names»

When importing CID-keyed PostScript fonts, there is a new option for whether glyphs should be named based on FontLab’s regular glyph naming heuristics, or by CID number, in Preferences > Open Fonts: “Change CID names to Unicode names when Unicode index is known”. This preference is on by default.

Enhancements»

Mask»

  • Previously, with mask layer visible and Edit Across Layers mode off, nodes from the mask layer were visible while editing outlines on another layer. Now, if you select nodes on the mask layer and switch back to another layer with Tools > Edit Mask, the associated handles from the mask layer are still visible (as in FontLab Studio 5). Handles on your drawing layer can then snap to the handles from the mask layer.

Drawing»

  • Edit > Find Outline search can be done for all glyphs or just for glyphs with a given tag.
  • Contour direction no longer affects the reported angle of node handles (visible on mouse hover or when handles are selected).
  • Free Transform now has a proxy to select the origin of the transformation, like the other transform modes/tools.

Guides»

  • You can now select different elements with the Guide tool, which is useful for quickly editing element guides.
  • When Element tool is active and Edit Across Elements mode is on, all element guides are visible.

Stroke»

  • FontLab applies strokes to elements after element transformations, similar to most drawing programs.
  • Expand operation produces more predictable results, works with element groups, and can be applied in the font window.
  • New Element > Remove Stroke command will remove stroke from the currently active element, or from all glyphs selected in font window.

Bug Fixes»

  • No longer causes a crash
    • Importing SVG artwork into more than one glyph cell at a time no longer causes a crash.
    • Tracing some particular image elements no longer causes a crash.
    • Repeatedly deleting elements no longer causes a crash.
    • Removing glyphs from an OpenType class no longer causes a crash.
  • Scripts listed in Scripts menu work properly, including submenus for folders.
  • When opening an existing font in OTF format, FontLab maintains the existing glyph index (GID) order.
  • In text sidebar, fixed interaction between escaped glyph names using “/” in main area, and glyphs entered in “left” and “right” fields.
  • Preferences for distances moved by cursor keys now also apply to moving guides, anchors and pins.
  • Right handle for sidebearing shows the resulting metrics live, while it is being moved.
  • Guides
    • Tags for guides are properly saved with the font, avoiding changes in guide colors.
    • No crash when adding several tags to guides using pop-up field from property bar.
    • Copy and paste are accepted in guide tag fields.
    • Typing is not slowed in guides pop-up field from property bar.
    • Element guides don’t move while editing contour.
  • Glyph position and zoom in glyph window are better preserved while cycling between glyphs with comma and period keys, including empty glyphs.
  • Zooming/scrolling in the glyph window works correctly even with unusually large elements.
  • Recompile OpenType features works even when ssXX features are named.
  • PythonQt nested widgets within widgets now have correct behavior for error messages and print commands, in the inner widget (directing stdout/stderr).
  • An “Instance font” created in variations panel retains glyph flags.
  • Text no longer “jumps” when its size is changed in a glyph window in metrics mode, but remains more centered/visible.
  • Improved centering of glyph when cycling through different glyphs in a Glyph Window.
  • Changing the OpenType class of a glyph is saved correctly in VFC files.
  • Changing glyph advance width to zero is saved correctly in VFC files.
  • Minimized glyph window does not become unreachable.
  • Edit > Paste Glyph Reference now correctly pastes a glyph reference instead of an unlinked glyph.
  • Placing a guide over a locked alignment zone no longer allows the locked zone to be moved.
  • Unusual/arbitrary weight values (usWeightClass) such as “401” are preserved in exported fonts.
  • Improved/fixed snap behavior with vector guides.
  • Glyph metrics now processed correctly when horizontal mirroring is applied to glyphs in the Font Window.

FontLab VI version 6.0.2.6578»

6 January 2018

As a special gift for the New Year, we extended the trial period for this build by ten days. Enjoy!

Crosshair cursor»

Crosshair cursor (FontLab Studio 5 style) is available as an option while using Contour, Pen and Rapid tools. It can be turned on in Preferences > Editing > Show cross.

Enhancements»

  • “Open Glyph Panel” command added to contextual menu in Font Window and Glyph Window.
  • Copying a selection of glyphs in the Font window gives a list of glyph names on the clipboard (for pasting into other apps)
  • In the dialog that appears when closing an unsaved font, the option “Don’t Save” can be triggered by the keyboard shortcut Command-Delete (Mac-only).
  • The New Layer dialog sets and maintains focus in name field.
  • Encoding menu of Font Windows remains open while handling groups of encodings.
  • Enter key triggers the OK button in more dialogs (excepting the most complex ones).
  • Placeholder characters are shown in Font Window after new empty glyphs are created.

Bug fixes»

Fixes in the 6.0.2 release include the following issues:

  • Some hints/links are lost when opening a MM font in VFB format.
  • FontLab VI sets itself as the default application for OTF and TTF files.
  • Brush tool is not using a high resolution cursor.
  • Arrow keys cannot move the contour while Free Transform is being used.
  • Actions do not work for the artwork on the Sketchboard.
  • Under certain conditions, a pasted contour is scaled up and flipped vertically.
  • Paste Special for metrics doesn’t change glyph status to edited.
  • Assigning OT class in Glyph panel only works on one at a time.
  • Cannot apply custom encoding not belonging to any group.
  • Cannot add glyphs to classes using the Classes panel.
  • Python scripting: .index attribute in CurrentGlyph().index of fgGlyph().index causes a crash.
  • Color transparency has no effect in Preview window.
  • Horizontal scrollbar does not work properly in Glyph Window.
  • Incorrect curve tension is applied in exported TTF fonts.
  • Generate Glyphs does not create non-standard ligatures.
  • Non-ASCII characters in the path prevent variable font to be exported.
  • Hebrew and Arabic placeholder characters are missing in Font Window.
  • Script chosen in the Preview panel is not remembered.
  • Glyphs named Tcedilla, tcedilla, Tcommaaccent and tcommaaccent are not handled correctly.
  • Element > Separate Contours to Elements disables Undo.
  • Tooltip for text size in Window bar uses a different format than default tooltips.

Windows-specific fixes:

  • Bezier handles are reset when using arrow keys.
  • Open kerning window with several glyphs causes a crash.
  • Profile dialog always shows information from the first one.
  • Custom profiles are not properly saved among sessions.

FontLab VI version 6.0.1.6558»

15 December 2017

Variation»

Use the “AAA” toggles on the right side of the masters list in Font Info > Masters to indicate which masters should take part in interpolation (creation of instances). If the “AAA” is shown, a master takes part in interpolation. If the “AAA” is hidden, the master does not take part in interpolation.

Paste and Duplicate»

Use the new Preferences > Paste & Duplicate section to control the offsets (x/y shift) for the Duplicate and Copy/Paste operations offsets and decide how imported or pasted artwork is scaled.

Bugfixes»

Fixes in the 6.0.1.6558 release include:

  • Change tooltip from “Add layer instance” to “Reset location to default” in the Variations Panel
  • Cmd (Ctrl)-scroll should give next/prev glyph in the Glyph window
  • Color marks (flags) are lost in vfb
  • Copied font guidelines are pasted as glyph guidelines
  • Crash on pasting a glyph in new font
  • Create Parallel Contour generates double points
  • Export to TTF adds many new nodes
  • File > Import > Artwork doesn’t open the dialog box
  • Header bar controls inactive for anchor position
  • Invalid DSIG when adding a signature
  • Missing references from other glyphs when importing Glyphs files
  • New updated vendor.dat file
  • Open (non-closed) contours are bad in the saved vfb
  • Paste Special pastes incorrect metrics
  • Selection is resized unexpectedly when using the link/unlink button
  • Show Rulers are always on after start
  • Sorting of layers when new glyph is created
  • Tags causes FL VI to crash in some situations
  • The Brush tool doesn’t work when the Toolbar is docked to window
  • Undo for Rapid tool is broken
  • Unicode codes should use uppercase
  • WOFF and EOT export without hinting, regardless of export settings

FontLab VI version 6.0.0.6550»

7 December 2017

  • Initial public release.