Toolbar»

The Toolbar is where all the tools in FontLab VI are housed. It is docked to the left edge of the screen in vertical orientation by default, but can be easily made horizontal if you prefer.

main-toolbar

  • You can show and hide the Toolbar by checking/unchecking the Window > Toolbar menu item.

  • To undock the Toolbar just press the mouse button anywhere on the grey area outside the buttons and drag-drop it from the screen edge. If the Toolbar was docked vertically it will remain vertical. Similarly if it was docked horizontally, it will remain horizontal.

  • When the Toolbar is undocked, you can move or dock it — click and drag anywhere on the grey area outside the buttons. You can dock it to any screen edge. It will be available for every open window if you have several open. If will reconfigure itself as vertical or horizontal to match the screen (or window) edge it is docked to.

  • In Preferences > General, if the first windows configuration option — All fonts and glyphs open in tabs — is selected, the Toolbar can be docked to windows as well:

Docking preferences

You can find the following buttons in the Toolbar:

Icon Tool Link
Contour tool Contour tool (A) for selecting, moving and editing points
Element tool Element tool (V) for moving elements
Edit Metrics tool Metrics tool (M) for editing metrics
Edit Kerning tool Kerning tool (K) for editing kerning
Text tool Text tool (T) for text keyboard input
Eraser tool Eraser tool (Q) for removing non-extrema nodes or, with +Shift+, any nodes
Brush tool Brush tool (B) for drawing brush strokes
Pencil tool Pencil tool (N) for creating and modifying contours freehand
Rapid tool Rapid tool (5) for very quick drawing of smooth curves
Pen tool Pen tool (P) for drawing Bézier curves
Knife tool Knife tool (J) for adding nodes and slicing outlines
Scissors tool Scissors tool (K) for disconnecting or opening contours
Magnet tool Magnet tool (U) for attaching points to guides
Fill tool Fill tool (F) for filling or unwilling contours
Guides tool Guides tool (G) for measuring and adding short guides
Match tool Matchmaker tool () for semi-automatic masters matching and harmonization
TrueType Hinting tool TrueType Hinting tool ++Cmd-Shift-F7++ for creating and modifying TrueType hints
Ellipse tool Ellipse tool (O) for drawing ellipses and circles
Rectangle tool Rectangle tool (I) for drawing rectangles and circles
Show all Nodes Show All Nodes View > Show > Nodes
Show Coordinates Show Coordinates View > Show > Coordinates
Show Curvature Show Curvature View > Show > Curvature
Show FontAudit Show FontAudit View > Show > FontAudit
Show Grid Show Grid View > Show > Grid
Show Guidelines Show Glyph Guidelines View > Glyph Guides
Show Font Guides Show Font Guidelines View > Font Guides
Show PostScript Hints View > Show > Hints

See the Tools page for information on activating tools using the keyboard.