Mask Layers»

A Mask Layer is a special layer in FontLab VI that can be used to temporarily keep things (like contours, images, etc.) while working in a main layer. Mask layers have the service attribute; that means they are are not rendered in the Font Window or the Preview panel. Apart from a regular Mask layer, which exists in a single glyph and can be seen in the Layers and Masters panel where its properties can be edited, there is also a Global Mask layer in FontLab VI. This type of mask is font-wide, doesn’t appear in the Layers and Masters panel, and has very limited features and operations.

Mask»

There can be several mask layers: each layer may have its own mask layer. All operations related to the Mask layer appear in the Tools menu. You can customize the color that is used to show the Mask layer using the Glyph Window page in the Preferences dialog box:

Creating a Mask layer»

To create a Mask layer, select the layer which you want the mask for (for example, the “Regular” layer if you are working on the Regular typeface) and choose Tools > Copy Outline to Mask (CmdM). A new mask layer will appear. If you had any selected contours in the main layer, they will be copied into the Mask layer; if not, the whole glyph will be copied to the mask layer.

Editing a Mask layer»

To edit a Mask layer with the usual editing tools, you need to first activate it in the Layers and Masters panel or using the Tools > Edit Mask (CtrlH) command.

When the Mask layer is selected for editing, the editing area changes its background color to remind you are in the Mask layer. Use any editing tool to create, edit or remove the nodes and contours of the Mask layer outline. When you are finished working on the mask, you can (re)activate the main layer by selecting it in the Layers and Masters panel or de-selecting the Tools > Edit Mask (CtrlH) command. You can also switch to the Mask layer and back to the main layer, by simply double-clicking the contours of the mask and outline. The editing area’s background color will change accordingly to display whether you are in the mask-editing mode or not.

If the option View > Snap > Mask is turned on, nodes on the main layer will snap to the contours on the Mask layer when they are moved. Similarly, nodes on the Mask layer will snap to the contours on the main layer when moved.

Removing a Mask Layer»

To remove a Mask layer, select it in the Layers and Masters panel and click on the button, or use the Glyph > Remove Layer command or use Tools > Clear Mask (CmdK). If you have more than one mask layer, you will need to remove each of them individually.

Global Mask»

The Global Mask is a special kind of mask that is font-wide and appears in all Glyph windows. Global Mask features and operations are very restricted: you can only copy a selected part of any glyph to the Global Mask, and you can clear it. The contents of the Global Mask cannot be edited, and it doesn’t appear in the Layers and Masters panel.

You can customize the color that is used to render the Global Mask on the Preferences > Glyph Window page:

Creating a Global Mask layer»

To create a Global Mask layer, Tools > Copy Outline to Global Mask (ShiftCmdM).

Removing a Global Mask Layer»

To remove a Mask layer, use Tools > Clear Mask (ShiftCmdK) command.

If the snap-to-global mask function (View > Snap > Global Mask) is on and the Global Mask layer is visible (View > Show > Global Mask), all nodes in all glyphs will snap to this template.