Skip to content

New in FontLab 8: Explore & prepare

Relax your eyes with the new dark or refined light interface theme. Group panels into a vertical infinite, scrollable panel dock, and intuitively navigate between the panels.

Adjust numeric values with sliders and calculations. Boost your productivity with up to 8× improved performance.

System requirements

macOS

FontLab 8 for Mac runs on macOS 10.14 Mojave, macOS 10.15 Catalina, macOS 11 Big Sur, and macOS 12 Monterey or later.

FontLab 8 can run with limited functionality on macOS 10.13.6 High Sierra, but some operations are not possible. We don’t provide technical support for this configuration. To run Python scripts in FontLab 8 on macOS 10.13.6 High Sierra, you need to apply a fix, read more.

Windows

FontLab 8 for Windows runs on Windows 8.1, Windows 10, and Windows 11 or later. We strongly recommend that you use 64-bit Windows and install the 64-bit version of FontLab 8. If you have a 32-bit system, you must install the 32-bit version of FontLab 8.

FontLab 8 can run with limited functionality of Windows 7, but exporting variable fonts and Python scripting is not possible. To export variable fonts on Windows 7, install Python 3.8.10 for Windows 7 and fontmake, then export DesignSpace+UFO from FontLab 8 and use python -m fontmake -m path_to_designspace.designspace -o variable. We don’t provide technical support for this configuration.

Linux, older systems

If you use CrossOver or Wine, FontLab 8 for Windows also may run on macOS 10.12 Sierra, on macOS 10.13 High Sierra, on Intel-based ChromeOS, and on Intel-based Linux systems. Those configurations don’t offer full functionality. We don’t provide technical support for these configurations.

Help, commands, shortcuts

Quick Help and Help panel

New Quick Help is updated for many user interface items.

Hold F1 (or FnF1) over any UI item, such as toolbar, panels or the property bar, to see the Quick Help text. Release F1 to hide Quick Help.

Tap F1 to permanently turn on Quick Help. Move over UI items to see Quick Help.

Before you click any menu, tap F1, then click a menu, and move over menu items to see Quick Help.

Tap F1 again to hide Quick Help.

Press ShiftF1 to open the Help panel. Place it so that you can conveniently read the text. New Then open Tools > Commands & Shortcuts. If the Help panel is not open, turn on ☰ > Open Help Panel. Then, type a partial name of a command. Click the command, and the Help panel shows its Quick Help text. Press / to navigate the list of commands and see the Quick Help text in the Help panel.

New The Help panel now has a Larger text toggle. Turn it on to make the text in the panel larger, turn off to make it smaller.

Commands & Shortcuts dialog

New When you choose Tools > Commands & Shortcuts or press ShiftCmdP ShiftCtrlP, the Commands & shortcuts dialog now opens as a compact popup, so you can type a substring of a menu command, choose it from the list, and press Enter to run the command.

Click ⚙️ (the gear button) to turn the compact Commands & shortcuts popup into a full dialog, where you can customize the keyboard shortcuts.

New We’ve restructured some menus, so some of your custom keyboard shortcuts will no longer work. Reassign them in the full Tools > Commands & Shortcuts dialog.

If a shortcut is occupied by another command, choose the command and click Clear. If you want to change a shortcut for a command that has a shortcut already, click Clear.

To assign a shortcut, click the empty text box at the bottom of the dialog, press your desired shortcut, then click Set.

Custom keyboard shortcuts with Alt and ShiftAlt

New If you open Tools > Commands & Shortcuts dialog and click the gear button, you can now assign custom keyboard shortcuts that use only the Alt modifier key plus some normal key, or a key with the ShiftAlt modifiers. For example, you can assign AltB or ShiftAltB to Contour: Balance.

The custom Alt-key shortcuts work in the Glyph and Font window, but if the Text tool is active or if your cursor is in a text field, the Alt key works as it normally does and inputs additional characters.

Note

In FontLab 8 for Windows, you cannot assign custom shortcut to Alt combinations with the letters C, E, F, G, H, M, S, T, V, W, X. FontLab uses these combinations to open the menus in the menu bar, for example, AltC opens the Contour menu. Also, on some Windows keyboard layouts, the custom keyboard shortcuts assigned to Alt-key combinations only work with the left Alt key. The right Alt key is used to enter special characters.

User interface

Dark or light theme

New FontLab 8 has a redesigned user interface, which now has two color themes (modes): dark or light. You can choose the theme in Preferences > General > Color theme.

By default, FontLab uses the System theme, so it starts with the dark or the light theme depending on your system setting:

  • on macOS: System Preferences > General > Appearance
  • on Windows 10 or newer: Settings > Personalization > Colors > Choose your color

Choose Light theme or Dark theme to always start FontLab with the given theme. You need to restart FontLab after you change its Color theme to see the change.

Dark theme

FontLab 8 dark theme on Windows, with Glyph window also in dark theme
FontLab 8 dark theme on Windows, with Glyph window also in dark theme

If FontLab runs with the dark theme:

New The Font window glyph cells use the dark theme by default. Turn off Preferences > Font window > Allow dark theme, and the Font window glyph cells will use the light theme.

New The Glyph window content uses the light theme by default. The Glyph window will use the dark theme if the Preferences > Glyph window > Background section:

  • has Allow dark theme turned on and the Background color is a light color such as white
  • New or has Allow dark theme turned off and the Background color is a dark color such as black (this works on macOS only)

New On macOS, you can set the Glyph window background color separately for the Metrics and Kerning modes (in Preferences > Spacing), for the Mask layer, and for all other editing modes (in Preferences > Glyph window > Background). If the background brightness is dark, the Glyph window will use the dark theme.

If you hold Space or `, the Quick preview of the Glyph window uses the light theme by default. Turn on Preferences > Glyph window > Also on preview, and Quick preview will use the dark theme.

Light theme

FontLab 8 light theme on macOS
FontLab 8 light theme on macOS

If FontLab runs with the light theme, the Font window glyph cells and the Glyph window content is always rendered with the light theme.

New In the light theme, the colors within the user interface are more consistent than in the previous version:

  • dialog boxes and panels use a slightly lighter gray than in FontLab 7
  • text boxes use a white background, also in large dialogs like Font Info and Preferences
  • toggles that are turned off have transparent background rather than white, but the background of a toggle becomes white if you hover over it
  • checkboxes are monochrome

User interface icons

New FontLab has updated user interface icons in many places, including the View panel, the Transform panel, the Elements panel, the Panels List panel, in the Font Info and Preferences dialogs, in the Font and Glyph window property bars, and in the toolbar.

The updated icons are less colorful, more visually consistent, and are more aligned with the design language of the newest versions of macOS and Windows.

New We have reorganized several menus to reduce clutter, accommodate additions, prioritize commonly-used entries, and move items closer if they are logically related.

Edit menu

  • In the Copy Element’s submenu, you can:
    • New Use the new Transformation command to copy the current element’s live transformation (position, live scale, live rotation and live slant). You can then select another element and choose Edit > Paste to apply the copied transformation to that element.
    • New Use the new Copy Stroke & Fill command to copy the stroke and fill attributes of some elements, and later paste (apply) them onto other elements.
  • Select All and Invert Selection are moved down.

Font menu

  • Generate Glyphs is now called Build Glyphs.
  • Add Glyphs is now called Add Glyphs from Catalog.
  • Detect Composites is moved up.
  • Metrics submenu has metric-related commands, including the new Auto Space.

Glyph menu

  • The Flag submenu is moved down.
  • The Layer submenu contains items that were previously directly in the menu, and are also accessible in the Layers & Masters panel: for adding/removing layers and switching between them.
  • Auto Layer / Auto Glyph is moved up so it’s together with component-related items.
  • Add Anchor is moved down, and Remove Anchors is moved from the Tools menu.
  • New You can use the new Set PS Direction command to set the direction of all contours in the glyph layer to PostScript (counterclockwise). Use Tools > Actions > Contour > Contour direction > Set PostScript direction to perform this on multiple layers.
  • Create Overlaps is moved up so it’s together with other contour-related commands.
  • FontAudit and Power Guides items are now in the Tools menu.
  • New The Add Sticker submenu is now at the end of Glyph menu, followed by the new Remove Stickers command.

Element menu

  • The New submenu on top replaces the New entries that were previously listed last.
  • The Arrange submenu has the Next Element and Previous Element navigational commands.
  • The Align submenu is moved up, so it’s right after Arrange.
  • The Place As Glyphs submenu is moved down, after Optically Separate.
  • The new Contours submenu has the new Sort Vertically and Sort Horizontally commands, and the Combine to Element and Separate to Elements commands that were previously directly in the menu.
  • The middle section of the menu has commands for the new and updated filters, followed by commands for removing and expanding transformation, filters and stroke.
  • The menu concludes with the Image submenu.

Contour menu

  • The Power Nudge toggle is no longer in the Contour menu. Instead, it’s in the Contour tool toolbox. To toggle Power Nudge, double-click the Contour tool icon in the toolbar to open the toolbox, and turn on the first icon, or press ShiftC.
  • Next Node and Previous Node are now in the Nodes submenu.
  • The Convert submenu has new commands, see the “Build & Assemble” chapter for more details.
  • The Loop Corners command creates looped corners in a selection. Once created, turn on Font Info > Other Values > Unfill looped corners to make them transparent.

Tools menu

  • The Guides submenu collects commands for adding a guide between nodes, removing guides of a certain type, and the Power Guide commands, moved from the Glyph menu.
  • The Hints submenu collects commands related to hints. TrueType Hinting is moved to the Tools > Tools submenu. For common operations like Autohint, we recommend that you use the keyboard shortcut.
  • The FontAudit submenu collects commands related to FontAudit, moved from the Glyph menu.

Panels

Scrollable panels dock

New The vertical panel stacks are now scrollable docks for panels. If you dock panels to the edge of the screen and the total height of the panels exceeds the vertical size of the screen, the entire stack of panels becomes scrollable.

So now, you can dock as many panels as you wish vertically, and you can enlarge the height of any of the docked panels. This now simply pushes down the panels docked below. You can even stack additional panels and dock them to the side of a scrollable dock, and the new dock also becomes scrollable.

New If the height of the docked panels exceeds the screen height, a zigzag appears at the top and/or bottom of the dock, which indicates that there is more content. Click the arrow on the zigzag to scroll dock by one full panel up or down, Shift-click to scroll to the top or bottom of the stack.

You can also use the wheel or trackpad to scroll the panels dock. If you move your pointer over a panel that has scrollable content itself (like the Kerning panel), scrolling within it takes precedence.

If you have docked the panels to the right edge of the screen, you can move your pointer over the left edge of the panel dock: a blue scroll bar appears, and you can always use it to scroll the entire dock. If the panels are docked to the left screen edge, the blue scroll bar appears over the right edge of the dock.

Opening, closing and activating panels

Previously, if a panel was open, you could close it by:

  • clicking the × button in its corner
  • right-clicking any panel header and choose the panel’s name
  • choosing the panel in the Window > Panels menu
  • pressing the keyboard shortcut assigned to the panel in Tools > Commands and Shortcuts

New Now, the system is more refined. If a panel is open, and you choose its name from the panel header context menu or from Window > Panels, or you press the panel’s shortcut:

  • If this panel has focus, its name in the Window > Panels menu is prefixed with “Hide”, and then FontLab closes (hides) the panel
  • If another panel or a window is active, FontLab brings the panel to the front and scrolls to it. #5906

New So if you press a panel’s shortcut twice, FontLab moves the focus to the panel, and then closes the panel. For example, you can press AltCmdP to show the Preview panel if it’s not visible or to go to it if it is visible, and then press the shortcut again to hide the panel.

New If a panel has focus, and you press Esc or CmdEnter CtrlEnter, FontLab moves the focus to the window.

If you turn on Preferences > General > Glyph window > Activate panels on object selection, and you select a particular type of object in the Glyph window (like a node, a guide or an anchor), the corresponding panel will become visible if it was open, but was outside the visible portion of the panel dock, or was in the back of a panel group. New This preference is off by default so that the scrollable dock does not “jump” up/down as you select various objects.

Edit > More Info: Open the right panel depending on current tool, selection or highlight

New With Edit > More Info AltCmdI CtrlAltI, you can open and go to the appropriate panel depending on what window, tab or panel you’re in, what tool you have selected, and what item you have selected or highlighted.

If you’re in a Font window, and you choose Edit > More Info, FontLab opens and goes to Font Info panel.

If you’re in a Glyph window and the Contour tool is active, and you select an item and choose Edit > More Info, FontLab opens the appropriate panel and goes to it depending on the selected item. If another tool is active, FontLab opens and goes to the appropriate panel depending on the active tool. If you’re in a panel you choose Edit > More Info, FontLab opens and goes to another panel.

Selected item To panel
point Node
guide, dimension, hint, zone Guides
anchor, pin Anchors and Pins
element, component Elements
From tool To panel
Element Elements
Metrics Metrics
Kerning Kerning
Text Preview
Eraser Glyph
Brush Brush
Pencil Stroke
Rapid Stroke
Pen Stroke
Thickness Stroke
Fill Color
From tool To panel
Scissors Glyph
Magnet Glyph
Guide Guide
Rotate Transform
Scale Transform
Slant Transform
Matchmaker Variations
TrueType Hinting TrueType Hinting
Ellipse Color
Rectangle Color
From panel To panel
Classes: kerning Kerning
Classes: OpenType Features
Classes: tags Glyph
Elements Layers
Features Classes
Font Info Fonts
Font Map Glyph
Fonts Font Map
Gallery Elements
Glyph Layers
Guide Measurements
From panel To panel
Image Elements
Kerning Pairs and Phrases
Layers Elements
Lookups Features
Measurements Font Info
Metrics Pairs and Phrases
Node Elements
Pairs and Phrases Metrics or Kerning
Scripting Output
Source Tables
Tables Scripting
Variations Layers & Masters

Tip

You can press AltCmdI CtrlAltI in succession to progressively see more info on a given topic. For example in Font window, press the shortcut to open the Font Info panel, press again to open Fonts, press again to open Font Map. Or when you’re in the Metrics mode of Glyph window, press the shortcut to open the Metrics panel, press again to open Pairs and Phrases panel, press again to go back to Metrics panel, and so on.

Window > Panels List

New In the Window > Panels List panel, you can click a panel’s icon to show/hide any panel.

New The panel now has Selections and TrueType Hinting. See below for information about the new Selections panel. The Window > Panels menu also shows all panels, including Selections and TrueType Hinting.

Hold F1 over any panel icon to see the updated Quick Help info.

The Panels List panel works great if you dock it to the right edge of the screen and resize it to one column. Then, dock the other panels to the left of it.

The last icon in the Panels List panel is a gear icon. Click it to choose which icons are shown in the Panels List panel. You can turn off the panels you use less and keep the Panels List visible at all times.

Collapsed panels

Normally, each panel is expanded and shows its content. You can resize the panel horizontally and vertically to make room for more content.

If the panel is not grouped with other panels, you can click the icon in the panel header. The panel then collapses, and only shows its header and, optionally, compact content in one line. Click the > icon to expand the panel again.

New Many more panels now show meaningful compact content if they are collapsed.

Font size in code editors

To change the global default font size used in the “code editors”, that is the Source, Scripting, Tables, Features, TrueType Hinting panels, and in the Lib areas of Font Info, use Preferences > Code editors and restart FontLab.

To individually change the font size in any of these code editors, click the editor area, hold Cmd Ctrl and press + to increase or - to reduce the size. New This now also works in the Features panel. FontLab keeps the individual font size adjustments until you restart the app, then it reverts to the global default font size.

Tools and the toolbox

Toolbox for the Contour, Eraser, Brush, Rapid, Pen, Knife, Scissors, Rectangle, and Ellipse tools

New Whenever you activate the Contour, Eraser, Brush, Rapid, Pen, Knife, Scissors, Rectangle, or the Ellipse tool, a small floating toolbox appears on the screen. This toolbox gives you single-click access to additional operations within each tool, often operations that are otherwise accessible with a modifier key.

If the toolbox is not visible for a given tool, double-click the toolbar icon to open the toolbox.

Click the × on the right side of the toolbox to close the toolbox for the given tool. Drag the toolbox to move it around (this changes the toolbox position for all tools).

New In most toolboxes, you can tap the tool’s shortcut key multiple times to toggle the mutually exclusive sub-tools. The last tap turns all sub-tools off, so the tool works in the default way.

Windows and tabs

Sketchboard is always optional

New If you work with only one window (Preferences > General > Windows/Tabs is set to Tabs), the Sketchboard is now optional. It only opens on startup if Preferences > Sketchboard > Open on startup is turned on, like in the other Windows/Tabs modes.

Right-click or Ctrl+click window title opens path dropdown on macOS

New In many macOS apps, if you right-click or Ctrl-click the window title, a dropdown opens that shows the filename and, beneath it, each folder portion. You can click any of these path components to open the folder in the Finder. FontLab 8 lets you do the same, so it’s easy to open Finder with the location of the current font file.

As in previous versions, you can also Cmd-click (Mac) or Ctrl-click (Windows) the Font tab heading to open a similar dropdown. This dropdown works on both macOS and Windows. This works only if the Font window is a tab, and works only with the Font tab (not a Glyph tab).

Unified controls for window bars

Previously, you could use the small, vertically arranged buttons on the rightmost side of the Glyphs bar to move the bar to the top or bottom of the Glyph window, and to close the bar.

New Now, other UI items have similar small buttons:

  • The rightmost side of the Glyph window property bar now has a button to close the property bar, and to move it to the top or bottom of the window.
  • The rightmost side of the Font window property and status bars now have a close button.
  • The rightmost side of the Metrics table now has the move, close and wrap buttons arranged vertically.

Note

Visit the Font window chapter to read about the changes to the Font window.

Glyph window

New We have updated the default settings for the View menu and panel, so that your Glyph window is less crowded by default.

Glyph window property bar

New The Glyph window property bar has new content in its default state, that is, when no nodes, elements or components are selected.

  • The center shows the glyph metrics (sidebearings and advance width), same as in the Metrics mode.
  • Between the Unicode field and the glyph metrics, a more compact glyph info section is located.
  • Hold the Glyph info button to see the glyph info popup with the glyph name and synonyms, the glyph preview, Unicode codepoint (with a new preview), name and category, and the new glyph layer bounding box info. In Font window, you can access the glyph info popup when you hold Space on a cell.
  • Next to the Glyph info button, the bar shows the number of elements, contours, and nodes.

New Some buttons in the Glyph window property bar are hidden if they’re not applicable:

  • the Flatten glyph button, if there are no components or multiple elements
  • the Apply kerning toggle if the font has no kerning
  • the Apply mark attachment toggle if the font has no mark attachment data

Glyph window zooming

When you use View > Zoom > Zoom 100% (Cmd3 Ctrl3), FontLab interprets the notion of 100% using the setting in Preferences > Distances > Glyph window zoom. New The setting now defaults to Fit to line height instead of Fit to safe metrics.

Text preview in the Glyph tab title

New If the new setting Preferences > Glyph Window > Tab title shows preview is turned on, the tab title shows a miniature preview of the Glyph window text, rendered in the current font. If the Glyph tab text contains just one encoded glyph, the tab title also renders it in system font. If the Glyph tab text contains just one unencoded glyph, the tab title shows the glyph name.

If the setting Tab title shows preview is turned off, the tab title shows the Glyph tab text rendered in system font.

View panel

In the View panel, you can quickly toggle visibility and snapping of various details of the Glyph window. The panel is a more efficient alternative to the View menu.

New We have updated the default settings for the View menu and panel, so that your Glyph window is less crowded by default.

Top View panel section

New The top section of the View panel used to be the 2nd section. It has a new layout:

  • the view details are rearranged into logical groups
  • if the visibility, snap or lock property is turned off for a given detail, the panel shows a small dot, like the right part of the Layers & Masters panel

Middle View panel section

New The middle section of the View panel used to be the 3rd section. It now has toggle buttons that control several of the same view details that are controlled in Preferences > Glyph Window.

At the beginning of the buttons list, you can now toggle:

  • All nodes: turn on to see all nodes, turn off to see only nodes near pointer; same as View > Show > Nodes.
  • Handles: turn on to see all handles, turn off to see only handles near pointers; same as View > Show > Handles.

Then, you can toggle:

  • Coordinates: turn on to see coordinates for selected nodes and handles, all nodes and handles, or key nodes, depending on the setting in Preferences > Glyph window > Coordinates > Show for; same as View > Show > Coordinates.
  • New Coordinates over node: turn on to see coordinates for nodes and handles that are under your pointer (cursor); same as Preferences > Glyph window > Coordinates > Show over node.
  • New Coordinates on canvas: turn on to see coordinates of your pointer in font units when you move the pointer around the Glyph window; same as Preferences > Glyph window > Coordinates > And on canvas.

The section also includes the Tunni lines toggle, which was previously in the top section. You can also tap L to hide/show Tunni lines, or hold L to show them temporarily.

At the end of the buttons list, you can toggle the same settings as in the Measure and Auto-meter sections of Preferences > Glyph window:

  • New Lengths & angles: turn on to see lengths and angles on handles and line segments.
  • New Curve tension: turn on to see the curve tension on handles (if Lengths & angles is also turned on).
  • New Stem widths: turn on to see the auto-metered stem thicknesses.
  • New Corner angles: turn on to see the angles of corners (if Stem widths is also turned on).

Click the gear icon at the end to show/hide icons in this section.

New If you collapse the View panel, it will show only the visible icons from this section, as many as the panel width permits.

Bottom View panel section

New The bottom section of the View panel used to be the 1st section. It now shows the content of the View > Suggest menu:

  • Suggest nodes
  • Suggest lines
  • Suggest bounds
  • Suggest tangents
  • Suggest guides
  • Suggest stems
  • Suggest distance

These buttons are no longer part of the View panel:

  • Power nudge: the toggle is now available in the Contour tool toolbox. You can toggle it with ShiftC, or hold C to activate it temporarily as you work in the Contour tool.
  • Preview rounding: the toggle was rarely used, and had no meaning if you have Font Info > Family Dimensions > Round coordinates turned on. If you work with fractional coordinates (that setting is turned off), you can still toggle Contour > Coordinates > Preview Rounding to see the true fractional positioning or the dynamically rounded positioning of items in the Glyph window.

Note

Visit the Consistency & precision chapter to read more about the changes to the Glyph window.

Preferences dialog

New preference pages design

New The list of preference pages is grouped into blocks for easier navigation.

New We have redesigned some pages in the Preferences dialog to make space for the new options. As a result, the Font window and Glyph window pages are now scrollable and show a “zigzag” at the bottom edge that indicates that there is more content.

Most panels that have scrollable content also use the zigzag indicator.

Searching preferences

New The Find page search box in the Preferences dialog is now on the top left above the pages list. To access it, click it or New press CmdF CtrlF.

New If you type a phrase into the Find page search box at the top-right of the Preferences dialog, the left-side pages list will show only the pages that contain matching settings.

Placeholder and caption font selector

In Preferences > Font Window, if you click the Default label for Placeholder font and Caption font, you can choose a different font from those installed on your system. New The custom font picker no longer uses the system font picker, but uses the same picker as File > Open > Installed Fonts…. Inside the font picker, you can easily filter the installed fonts by writing system.

Applying preferences

To apply the preferences and to close the Preferences dialog, click the OK button or New you can press CmdEnter CtrlEnter.

Grid slant angle

New In Preferences > Grid, Guides and Hints > Slant angle, you can now use higher decimal precision, and you can define the grid slant angle as a X/Y slope ratio. This is an alternative way of specifying the slant angle, which FontLab has used for italic angle in Font Info > Font Dimensions > Slope.

Other user interface changes

Numeric controls with slider and calculations

Most numeric text boxes in the user interface have new functionality:

  • New Click at the right edge of the box to open a slider. Drag the slider to change the value, hold Ctrl move the slider at higher precision.

  • New Enter simple calculations into the box like 300+50 or 300*1.2 and press Enter to put the result into the box.

Seach boxes

New We have redesigned the search boxes across FontLab.

  • Each search box has an industry-standard loupe icon.
  • The placeholder in the search box on top of the Font window and Glyph window says Search.
  • The placeholders in other search boxes say Find, followed by the type of item you can search for, for example Find glyph in the Classes panel. Previously, the placeholders in these search boxes said Filter.
  • In the Gallery panel, the search box placeholder still says Filter.
  • In the Preferences, Font Info and Actions dialogs, the search box is now on the top left. To access it, click it or New press CmdF CtrlF.

Customizing the user interface

You can use Python scripting to customize the user interface of FontLab more deeply, for example use a custom font or change some UI colors. Place a file named initScript.py in your user data folder. To open the user data folder, go to Preferences > General > User data, and click the folder icon. Inside the file, place the Python code that FontLab will run when it starts. You can use the example below for inspiration.

from PythonQt import QtGui
qapp = QtGui.QApplication.instance()

# Change the app UI font to a custom TTF, more info see:
# https://doc.qt.io/qtforpython-5/PySide2/QtGui/QFont.html
# https://doc.qt.io/qtforpython-5/PySide2/QtGui/QFontDatabase.html
fdb = QtGui.QFontDatabase()
fontid = fdb.addApplicationFont("/Users/YOURNAME/Library/Fonts/YOURFONT.ttf")
if fontfamilies := fdb.applicationFontFamilies(fontid):
    appfont = qapp.font()
    appfont.setFamily(fontfamilies[0])
    qapp.setFont(appfont)

# Modify the color palette, see more info:
# https://doc.qt.io/qtforpython-5/PySide2/QtGui/QPalette.html
palette = qapp.palette()
palette.setColor(QtGui.QPalette.Button, QtGui.QColor(200, 237, 255))
palette.setColor(QtGui.QPalette.ButtonText, QtGui.QColor(0, 0, 0))
qapp.setPalette(palette)

Warning

We don’t provide technical support for these types of customization.